Owncloud 8 !

Pour poser ses questions sur le fonctionnement du forum ou pour proposer des idées et des suggestions.

Owncloud 8 !

Message par piera5 » 19 Jan 2016, 09:54

Bonjour,
hier j'ai commencé à préparer le compte-rendu de la sortie de dimanche et j'ai déposé les photos sur owncloud. Surprise il a été passé en version 8, génial !

En revanche la manip que je faisais pour partager la photo, copier le lien obtenu puis l'affichage sur le forum avec le "bouton" cloudimage ne fonctionne plus.
Je mets un exemple ci-dessous :
Lien de la photo partagée = http://cloud.vttnet.org/index.php/s/qy0e0PaPFLt5Lhk
Lien cloudimage = Image Owncloud

Sauriez-vous comment résoudre ce problème ?
J'ai cherché sur Internet mais n'ai pas encore trouvé de solution.
A bientôt,
Pierre.
-----
Pertuis (84)
Avatar de l’utilisateur
piera5
Picousé VTTnet
 
Message(s) : 1507
Inscription : 30 Avr 2010, 15:09
Localisation : Vaucluse
Club VTTnet: Inscrit 2014

Re: Owncloud 8 !

Message par Carbone » 19 Jan 2016, 10:02

Problème connu, Roudou y travaille.
Carbone.
Alors que certains sont en marche, nous, on roule ...
Avatar de l’utilisateur
Carbone
Juste Mango
 
Message(s) : 11208
Inscription : 19 Oct 2004, 19:02
Localisation : Près de Nancy 54 - France
Club VTTnet: Inscrit 2014

Re: Owncloud 8 !

Message par piera5 » 19 Jan 2016, 10:12

Carbone a écrit :Problème connu, Roudou y travaille.


Ok merci pour la réponse.
A bientôt,
Pierre.
-----
Pertuis (84)
Avatar de l’utilisateur
piera5
Picousé VTTnet
 
Message(s) : 1507
Inscription : 30 Avr 2010, 15:09
Localisation : Vaucluse
Club VTTnet: Inscrit 2014

Re: Owncloud 8 !

Message par roudou » 19 Jan 2016, 11:22

piera5 a écrit :En revanche la manip que je faisais pour partager la photo, copier le lien obtenu puis l'affichage sur le forum avec le "bouton" cloudimage ne fonctionne plus.
Je mets un exemple ci-dessous :
Lien de la photo partagée = http://cloud.vttnet.org/index.php/s/qy0e0PaPFLt5Lhk
Lien cloudimage = Image Owncloud

Sauriez-vous comment résoudre ce problème ?
J'ai cherché sur Internet mais n'ai pas encore trouvé de solution.


En effet, avec la version 8 de owncloud les urls de visualisation des partage change. Du coup la balise
Code : Tout sélectionner
[cloudimage]url de partage[/cloudimage]
ne fonctionne plus.

La bonne nouvelle c'est que les balises des partages réaliseés avant le passage à la version 8 son toujours valables.
La mauvaise c'est que la recette ne fonctionne plus avec les partage réalisés depuis la version 8.

C'est dommage, mais en fait la méthode exploitée sous oncloud 8 est bien plus efficace.
Il est maintenant possible de composer une url qui demande l'affichage d'une image ayant des caractéristiques bien définies. Préciser la largeur et la hauteur maximale, si le ratio largeur/hauteur doit être respecté et si l'image doit éventuellement être agrandie aux dimensions précisées. Enfin si l'image est plus petite, elle sera recalculée par le serveur pour épargner la bande passante.

La méthode la plus simple actuellement pour afficher sur le forum vos nouveaux partages provenant du cloud vttnet est de procéder comme ceci:

1- Partager votre image par lien public.
2 - utiliser le lien pour afficher le partage; ce qui va afficher l'image dans une résolution raisonnable.
3 - cliquer sur l'image avec le bouton droit de la souris
4 - dans le menu qui s'ouvre, choisir "copier l'adresse de l'image"
5 - coller cette url dans un balise bbcode "img" sur le forum

Cela va fonctionner.

Et pour ceux qui veulent bidouiller, il suffit de regarder le contenu de l'url de l'image partagée pour comprendre comment on peut s'amuser à en modifier facilement les caractéristiques selon les effets recherchés.

C'est pour le moment le mieux que je puisse vous proposer en attendant une prochaine amélioration.

Concernant owncloud 8 vous pourrez remarquer que deux sous-applications on été ajoutées. Une gestion de galeries d'images, et un agenda. Pour accéder à ces sous-applications il convient de dérouler le menu situé en haut à gauche de l'écran en cliquant dessus. D'autres applications qui nous seront utiles viendront certainement s'y ajouter, mais pour en profiter pleinement il faudra peut-être faire évoluer l'hébergement pour disposer de ressources qui ne sont pas disponibles actuellement.
Avatar de l’utilisateur
roudou
Picousé VTTnet
 
Message(s) : 3737
Inscription : 30 Août 2004, 09:32
Localisation : Gelbiquie
Club VTTnet: Membre fondateur

Re: Owncloud 8 !

Message par Brup » 19 Jan 2016, 13:36

salut,
moi aussi j'ai constaté le pb de lien avec owncloud.

j'ai noté un changement dans les liens:
Avant les liens étaient de la forme :
http://cloud.vttnet.org/public.php?service=files&t=<photo_id>

Maintenant quand on fais partager par lien public, le lien est de cette forme:
http://cloud.vttnet.org/index.php/s/<photo_id>

Il faut utiliser quel lien dans les balises cloudimage ?

Que deviennent les anciennes pages avec d'anciennes photos?
Avatar de l’utilisateur
Brup
Picousé VTTnet
 
Message(s) : 2838
Inscription : 20 Sep 2004, 19:54
Localisation : près de Grenoble, Isère, France
Club VTTnet: Inscrit 2014

Re: Owncloud 8 !

Message par RouelibrE » 19 Jan 2016, 16:58

Brup a écrit :
Que deviennent les anciennes pages avec d'anciennes photos?


RTFM :P
-->
roudou a écrit : La bonne nouvelle c'est que les balises des partages réaliseés avant le passage à la version 8 son toujours valables.
RouelibrE
Cycliste de plaisance
Avatar de l’utilisateur
RouelibrE
Picousé VTTnet
 
Message(s) : 5842
Inscription : 01 Sep 2004, 10:15
Localisation : Lyon - France -
Club VTTnet: Inscrit 2014

Re: Owncloud 8 !

Message par roudou » 19 Jan 2016, 18:58

Brup a écrit :j'ai noté un changement dans les liens:
Avant les liens étaient de la forme :
http://cloud.vttnet.org/public.php?service=files&t=<photo_id>

Maintenant quand on fais partager par lien public, le lien est de cette forme:
http://cloud.vttnet.org/index.php/s/<photo_id>

Il faut utiliser quel lien dans les balises cloudimage ?

Que deviennent les anciennes pages avec d'anciennes photos?


J'imagine que quand tu as écris ceci tu n'avais pas encore lu mes explications.
Autrement je t'invite à les relire.
C'est juste au dessus.
Avatar de l’utilisateur
roudou
Picousé VTTnet
 
Message(s) : 3737
Inscription : 30 Août 2004, 09:32
Localisation : Gelbiquie
Club VTTnet: Membre fondateur

Re: Owncloud 8 !

Message par Brup » 20 Jan 2016, 11:51

Salut roudou,
J'avais lu ton message, mais lorsque je vois que plus aucun de mes anciens liens ne fonctionnent (temporairement), j'ai eu un doute sur la comprehension de ton message et j'ai eu besoin d'une confirmation.
Merci pour la précision.
Avatar de l’utilisateur
Brup
Picousé VTTnet
 
Message(s) : 2838
Inscription : 20 Sep 2004, 19:54
Localisation : près de Grenoble, Isère, France
Club VTTnet: Inscrit 2014

Re: Owncloud 8 !

Message par Brup » 28 Jan 2016, 22:00

Désolé d'en remettre une couche mais quand roudou dit
La bonne nouvelle c'est que les balises des partages réaliseés avant le passage à la version 8 son toujours valables.


Et que je m'interroge sur la validité des anciens liens on le répond rtfm.

Ce que je veux dire c' est qu'en regardant des vieux CR que j'ai fait, les liens ne marchent plus.
Avatar de l’utilisateur
Brup
Picousé VTTnet
 
Message(s) : 2838
Inscription : 20 Sep 2004, 19:54
Localisation : près de Grenoble, Isère, France
Club VTTnet: Inscrit 2014

Re: Owncloud 8 !

Message par didod51 » 04 Mai 2016, 11:37

roudou a écrit :1- Partager votre image par lien public.
2 - utiliser le lien pour afficher le partage; ce qui va afficher l'image dans une résolution raisonnable.
3 - cliquer sur l'image avec le bouton droit de la souris
4 - dans le menu qui s'ouvre, choisir "copier l'adresse de l'image"
5 - coller cette url dans un balise bbcode "img" sur le forum

Cela va fonctionner.


Est ce toujours cette technique qu'il faut utiliser pour poster une photo, j'ai fais plein d'essai. Pas moyen d'afficher une photo...

Image

http://cloud.vttnet.org/index.php/apps/files/?dir=%2FLoueNet%20Pres%C2%B0#

Image Owncloud

http://cloud.vttnet.org/index.php/apps/ ... res%C2%B0#
Avatar de l’utilisateur
didod51
Pédalator
Pédalator
 
Message(s) : 904
Inscription : 10 Sep 2012, 19:40
Localisation : epinal (Vosges)
Club VTTnet: Inscrit 2014

Re: Owncloud 8 !

Message par roudou » 04 Mai 2016, 11:43

didod51 a écrit :
roudou a écrit :1- Partager votre image par lien public.
2 - utiliser le lien pour afficher le partage; ce qui va afficher l'image dans une résolution raisonnable.
3 - cliquer sur l'image avec le bouton droit de la souris
4 - dans le menu qui s'ouvre, choisir "copier l'adresse de l'image"
5 - coller cette url dans un balise bbcode "img" sur le forum

Cela va fonctionner.


Est ce toujours cette technique qu'il faut utiliser pour poster une photo, j'ai fais plein d'essai. Pas moyen d'afficher une photo...

Image

Les liens que tu mentionnes sont ceux correpsondant à ton fichier.
Ce ne me semble pas un lien de partage public.

http://cloud.vttnet.org/index.php/apps/files/?dir=%2FLoueNet%20Pres%C2%B0#

Image Owncloud

http://cloud.vttnet.org/index.php/apps/ ... res%C2%B0#
Avatar de l’utilisateur
roudou
Picousé VTTnet
 
Message(s) : 3737
Inscription : 30 Août 2004, 09:32
Localisation : Gelbiquie
Club VTTnet: Membre fondateur

Re: Owncloud 8 !

Message par didod51 » 04 Mai 2016, 11:47

roudou a écrit :
didod51 a écrit :
roudou a écrit :1- Partager votre image par lien public.
2 - utiliser le lien pour afficher le partage; ce qui va afficher l'image dans une résolution raisonnable.
3 - cliquer sur l'image avec le bouton droit de la souris
4 - dans le menu qui s'ouvre, choisir "copier l'adresse de l'image"
5 - coller cette url dans un balise bbcode "img" sur le forum

Cela va fonctionner.


Est ce toujours cette technique qu'il faut utiliser pour poster une photo, j'ai fais plein d'essai. Pas moyen d'afficher une photo...

Image

Les liens que tu mentionnes sont ceux correpsondant à ton fichier.
Ce ne me semble pas un lien de partage public.

http://cloud.vttnet.org/index.php/apps/files/?dir=%2FLoueNet%20Pres%C2%B0#

Image Owncloud

http://cloud.vttnet.org/index.php/apps/ ... res%C2%B0#



Image

http://cloud.vttnet.org/index.php/s/PZehie25FYr10C4

Image Owncloud

J'ai pris le lien de partage, ça ne fonctionne pas nons plus
Avatar de l’utilisateur
didod51
Pédalator
Pédalator
 
Message(s) : 904
Inscription : 10 Sep 2012, 19:40
Localisation : epinal (Vosges)
Club VTTnet: Inscrit 2014

Re: Owncloud 8 !

Message par Tophee » 04 Mai 2016, 11:53

Et comme cela?


Image
Avatar de l’utilisateur
Tophee
Pédalator
Pédalator
 
Message(s) : 571
Inscription : 05 Août 2014, 07:34

Re: Owncloud 8 !

Message par Tophee » 04 Mai 2016, 11:54

J'ai fait un clic droit sur limage affichée par owncloud -> copier l'adresse de l'image, puis je l'ai insseré dans le message comme une image normale, avec les tag img
Avatar de l’utilisateur
Tophee
Pédalator
Pédalator
 
Message(s) : 571
Inscription : 05 Août 2014, 07:34

Re: Owncloud 8 !

Message par didod51 » 04 Mai 2016, 11:58

Image
Avatar de l’utilisateur
didod51
Pédalator
Pédalator
 
Message(s) : 904
Inscription : 10 Sep 2012, 19:40
Localisation : epinal (Vosges)
Club VTTnet: Inscrit 2014

Suivant

Retour vers Questions et suggestions sur le forum

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 1 invité